Please select To the mobile version | Continue to access the desktop computer version
| |

Kaosun's CD Players

 Forgot password?
 Repair!
Search
View: 528|Reply: 3

Sony D-50 can't detect disk

[Copy link]

1

Threads

3

Posts

55

Credits

Member

Rank: 2

Credits
55

 Japan

Post time: 2020-08-29 00:15:11
| Show all posts |Read mode
Hello everyone here ;)
I recently brought a Sony D-50 (Seller claim it as unknown condition) from internet and here's the sympton and my diagnose:

1. Disk starts spin about 2-3 sec, automaticly power off (no disk dectection)
2. Laser foucs lens went up and down. (Seems focus coil works)
3. There is Laser emitted, observed red light.

--------Then I download and read the service manual and all thread in this form and jdbbs--------

4. S901 laser emit switch works good.
5. Measured there is 54mA when laser emits by put a multimeter in the middle of S901 output. (Seems laser diode still okay)
6. Confirmed S901 and S902 switch are functional. (Not a simple fix)

-------I followed service manual and solded BATT2 point to boot D-50 into service mode--------

7. Confirmed S903 is functional as well by moving the SLED
8. SLED mechanical part is in a good shape, all gears and motor runs good.
9. Focus coil seems in a good shape as well: A) It pops out when I flip it over (buttom up). B) It went up and down by +3mm -2mm distance. C) IC506 pin5 and pin8 outputs 1.2~3.8vDC to driving focus.
10. Tracking coil was in a unknown status by: A) Visually not moving. B) IC507 pin5 and pin8 outputs ~0.23vDC during focus.
11. Spin motor didn't move. Even I pressed [Play/Pause] button, only focus works. In the same time I feel there is a virbaration happend very shortly ~0.5sec. I measured the V Battery pin (WHT cable) on M901 have voltage drop from 9.7v idle to 8.2v in 0.5sec after I pressed [Play/Pause] button. I checked the spinder and bearing is good and smooth.
12. Laser focus mirror module generates "jizzzzzzz" sound once power been plugged and booted into service mode without touch any key. (Not sure if this sounds generates by tracking coil) Once I press [Stop] button the sounds will be disappear ~0.5sec.
13. It come with Sony original power brick which have 9.7v output.
14. DC-DC convertor module seems good: Vin=9.7v, Vdrive-9.68v, Vref=2.38v, +5=5.2v, -5=-5.2v.

--------End of diagnose--------

I'm a newbee and have some basic analog ciruit knwoleadge.
I have a RMS multimeter and solderig tools at hand.

My questions:
- Which compoents possibly goes wrong? (I feel the jizzzzz sounds from focus mirror is weird)
- Is an osciloscope a must or a nice-to-have gear to get this fixed? If so, can a digital one works in this case? (I heared from lots discuss that analog one is more direct when look into "eye partten")

Thanks for reading my long thread and I wish we could having fun to digging into this together. ^_^

Reply

Use magic Report

365

Threads

611

Posts

3778

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
3778

 Invalid IP Address

Post time: 2020-09-08 08:59:05
| Show all posts
It seems the laser is bad. Ordinary I'll replace the laser diode which is a SHARP LT022MC. An analog oscilloscope is a must to check RF eye pattern. Digital oscilloscope can hardly work on the pattern. Any analog oscilloscope like KENWOOD CS4135 30MHz or TEKTRONICS 4426 100MHz will work on the signal.

There's several posts here regarding laser diode replacement of the LT022MC, pls take a look whether you can follow or have someone to repair it.
Reply Support Not support

Use magic Report

1

Threads

3

Posts

55

Credits

Member

Rank: 2

Credits
55

 Japan

 Author| Post time: 6 day(s) ago
| Show all posts
kaosun 2020-09-08 08:59
It seems the laser is bad. Ordinary I'll replace the laser diode which is a SHARP LT022MC. An analog ...

Thanks for your reply Kaosun!

My LD module got 58.8mA standard current on its label and the current I measured is within the range.(-5 ~ +11 mA)
Is this still means laser is bad?

After I clean up the both side of focus mirror, now in the service mode the main motor will starts to spin after I press [Play/Pause] button and a focus.

I got an analog scope to measured the RF signal which is pretty bad only 0.7v P-P.
Tired to adjust the focus bias, tracking/focus gain, tracking balance and seems not help with the situation.

My question is after replaced the laser diode with SHARP LT022MC, how to ensure the optical alignment of the whole pick up system? As I don't trust myself regarding assemble technique.
Reply Support Not support

Use magic Report

1

Threads

3

Posts

55

Credits

Member

Rank: 2

Credits
55

 Japan

 Author| Post time: 4 day(s) ago
| Show all posts
Edited by yoyo at 2020-09-17 02:56

- After I cleaned the dual side of focus lens, this is the RF signal I got. (With the laser in the middle of SLED track and a SONY YEDS-1 test disk)
- There is no major difference on the position of the CD Player. (Top-Down, Buttom-Up and Vertical)
- If I move laser away from 0 Track by press >>| key in the service mode, the amplitude (P-P voltage) of RF signal became more weak.


This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Repair!

Points Rules

Archive|Mobile|Dark room|Kaosun's CD players

2020-09-21 13:13 GMT-6 , Processed in 0.017354 sec., 14 queries .

Powered by Discuz! X3.2

Release 20141225, © 2001-2020 Comsenz Inc.

MultiLingual version, Rev. 441, © 2009-2020 netdepviet.org

Quick Reply To Top Return to the list