Please select To the mobile version | Continue to access the desktop computer version

Kaosun's CD Players

 Forgot password?
 Repair!
Search
View: 4779|Reply: 4

Sony D-515 right channel not working correctly.

[Copy link]

7

Threads

34

Posts

301

Credits

Full Member

Rank: 3Rank: 3

Credits
301
Post time 2020-12-26 06:14:00 From the mobile phone | Show all posts |Read mode
Hello everybody here!
I recently bought a d-515 in "untested" condition. After some capacitors and a little bit of laser adjustment, the unit reads discs perfectly. Now, the only issue that remains is that the right channel is not working propertly (in both line out and headphones, batteries or 9V DC). It can be heard at a lower volume, cracking. If you apply hot air on the main board for 5 seconds, then the channel works fine for the rest of the day. The area is far away from electrolyte and nothing can explain a bad soldering. Since the left channel is always working fine, I suppose that all the digital circuit is ok and the error is somewhere between the DAC and the line out jack. (tell me please if this assumption is wrong). Since the left channel is working always, I don't think this is a power supply problem. What can the error be, can it be a transistor or a resistor? Can the DAC cause this error?
Any help is greatly appreciated!
Thanks a lot!
Reply

Use magic Report

456

Threads

737

Posts

4415

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
4415
Post time 2021-01-09 12:46:20 | Show all posts
Classic cap issue. Suggestion: replace all SMT caps with original parameters and clean the leaking.
Reply Support Not support

Use magic Report

7

Threads

34

Posts

301

Credits

Full Member

Rank: 3Rank: 3

Credits
301
 Author| Post time 2021-01-14 05:32:26 From the mobile phone | Show all posts
Hello! I am so happy to hear that! Capacitors are the next step. I was a bit confused because this happens only on the one channel. Again, thanks a lot for your help!
Reply Support Not support

Use magic Report

7

Threads

34

Posts

301

Credits

Full Member

Rank: 3Rank: 3

Credits
301
 Author| Post time 2021-04-20 11:50:27 | Show all posts
Hello again, I have now replaced all the capacitors, cleaned all the leak. No broken lines under any capacitor. The problem remains the same ( Right channel distorted in both line out and headphones) The weird thing is, that if i warm up the unit just a little, it will play fine for a few hours... I also looked for a cracked solder, but i couldn't find anything. What could it be? can it be the DAC? (The voltages are fine) any ideas???
Thanks a lot for any help!
kostgeor
Reply Support Not support

Use magic Report

456

Threads

737

Posts

4415

Credits

Administrator

Rank: 9Rank: 9Rank: 9

Credits
4415
Post time 2021-04-20 14:17:34 | Show all posts
Follow the service manual, check the DAC and pre-amp. Ordinary broken via or trace.
Reply Support Not support

Use magic Report

You have to log in before you can reply Login | Repair!

Points Rules

Archiver|Mobile|Dark room|Kaosun's CD players

2021-09-22 20:51 GMT-6 , Processed in 0.025180 second(s), 20 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

Quick Reply To Top Return to the list